Redirecionando do tráfego web como MIkrotik paralelo

Henrique Fernandes Silveira
Developer
2011-06-13 18:41:59 Responder Post

Suponto a seguinte topologia:

LINK > Speedr, Mikrotik

Note que o Speedr tem uma interface dedicada a ele, no exemplo ele fica com o IP 192.168.254.2/30 e o mikrotik nesta interface o ip 192.168.254.1/24.

Obs: A rota padrão (gateway default) do Speedr deve apontar para o Mikrotik 192.168.254.1.

O mikrotik no exemplo serve a rede como gateway no Ip 192.168.1.1/24.

interdaces

Adicione as regras ao mikrotik, apenas copiando as regras e adicionando clicando em "New Terminal", como mostra as imagens a seguir.

São duas regras basicamente em Nat e Mangle

A regra abaixo marca os pacotes com destino a porta 80 (web), cuja a range de IPs esteja adicionada na adress-list.

MANGLE

/ip firewall mangle add action=mark-connection chain=prerouting comment="if addrlist = speedr-redirect -> mark connection [connmark_speedr-redirect]" disabled=no dst-address-list=!intranet dst-port=80 new-connection-mark=connmark_speedr-redirect passthrough=no protocol=tcp src-address-list=speedr-redirect

mangles

Essa regra redireciona os pacotes marcados pela regra mangle para o Speedr na porta 3128, exceto o que tenha destino a rede interna, ou seja os ips que serão adicionados na address-list "intranet".

NAT

/ip firewall nat add action=dst-nat chain=dstnat comment="if [connmark_speedr-redirect]-> redirect [192.168.254.2 tcp.dst=3128]" connection-mark=connmark_speedr-redirect disabled=no dst-address-list=!intranet protocol=tcp to-addresses=192.168.254.2 to-ports=3128

mangle

Ao final adicionar a CIDR da rede local na address-list, dessa forma redirecionaremos a rede 192.168.1.0/24.

A address-list intranet serve para negar o destino a servidores da rede interna, ou seja, se tiver um servidor web em uma rede 192.168.20.0/24, basta adiciona-los na address-list "intranet", para que o tráfego para ele não passe pelo Speedr.

ADDRESS-LIST

/ip firewall address-list add address=192.168.1.0/24 comment="" disabled=no list=intranet

/ip firewall address-list add address=192.168.1.0/24 comment="Regra webcache" disabled=no list=speedr-redirect

address-list

Dica de mascaramento NAT

Considerando a nossa topologia, a seguir, uma dica para fazer o mascaramento corretamente sem fazer nat dos clientes para o speedr, dessa forma aparecerá o IP dos clientes e não do mikrotik na lista de Clientes conectados do Speedr.

MASQUERADE INTRANET

/ip firewall nat add action=masquerade chain=srcnat comment="Masquerade intranet" disabled=no dst-address=!192.168.254.2 src-address-list=intranet

MASQUERADE SPEEDR

/ip firewall nat add action=masquerade chain=srcnat comment="Masquerade speedr" disabled=no dst-address-list=!intranet src-address=192.168.254.2

masquerade


jorge luiz alves da silva junior

2011-06-14 01:03:27 Responder  

mais eu conecto meu servidor com link adsl entao ele disca toda vez e muda o ip essa configuracao serve pra ele?

jorge luiz alves da silva junior

2011-06-14 01:05:39 Responder  

outra duvida na hora que eu to instalando o spped dr eu coloco dhcp sim ou nao se colocar sim ele pega o ip automatico que o servidor vai redirecionar? e se colocar nao tenho que colocar manual pode me diser como configurar para ficar igual ta nesse tutorial pra naop da erro? desculpe as perguntas so meu leigo na plataforma linux

Roger Souza da Silva

License Level: 3
2011-06-14 09:14:53 Responder  

Muito boa, Henrique.

Depois de um pequeno ajuste, funcionou perfeitamente.

Vou passar a correção para os próximos leitores não quebrarem a cabeça.

Na tua regra Mangle tu mandou marcar os pacotes que estivessem no Address Lists com o nome de speedr-redirect. Conforme abaixo.

MANGLE

/ip firewall mangle add action=mark-connection chain=prerouting comment="if addrlist = speedr-redirect -> mark connection [connmarkspeedr-redirect]" disabled=no dst-address-list=!intranet dst-port=80 new-connection-mark=connmarkspeedr-redirect passthrough=no protocol=tcp src-address-list=speedr-redirect

E no Address Lists tu colocou esta regra com o nome speedr-redir. Conforme abaixo.

/ip firewall address-list add address=192.168.1.0/24 comment="" disabled=no list=intranet

/ip firewall address-list add address=192.168.1.0/24 comment="Regra webcache" disabled=no list= speedr-redir

Pessoal, basta alterar esta última linha para:
/ip firewall address-list add address=192.168.1.0/24 comment="Regra webcache" disabled=no list= speedr-redirect

Mais uma vez agradeço a dedicação, sem esta tua postagem eu acho que não conseguiria colocar o servidor no ar.

Agora é só testar.

Grande Abraço.

Róger Silva

Henrique Fernandes Silveira
Developer
License Level: 8
2011-06-14 18:23:37 Responder  

Jorge, se ele disca pppoe, ele vai pegar ip e rota padrão para internet normal, vai funcionar. Não recomendo que use DHCP, não há necessidade, coloque IP fixo e rota padrão para o mk, este trecho explica isso:

Note que o Speedr tem uma interface dedicada a ele, no exemplo ele fica com o IP 192.168.254.2/30 e o mikrotik nesta interface com o ip 192.168.254.1/24.

Obs: A rota padrão (gateway default) do Speedr deve apontar para o Mikrotik 192.168.254.1.

Detalhe Speedr é baseado no kernel do freebsd, não é linux.

Obrigado Roger já corrigi.

Abraços

lazaro vieira gome

License Level: 3
Há 2013-05-03 19:14:16  

amigo henrique vc tem alguma regra q funcione dessa foram ( tenho planos de 300,600.1mb e gostaria q meu cliente de 300 pega-se do cache saindo em 800 , o de 600 pega-se do cache 1mb e o de uma 1mb pega-se do cache 2mb fico grato se vc mu ajuda-se

ronaldo chaves

2011-06-16 10:55:22 Responder  

Henrique ;como é a topologia para isto .
link (modem bridge)>> speedr 2 placas de rede, entra link a outra sai link é isto >>mk(discando pppoe) adicionar mais 1 placa de rede para conectar o speddré isto
em rotas coloco o que ? tem la subredes e gateway já fiz varias tentativas e não grava rotas.

Henrique Fernandes Silveira
Developer
License Level: 8
2011-06-16 23:23:46 Responder  

Neste caso o Speedr tem apenas uma placa:

Note que o Speedr tem uma interface dedicada a ele, no exemplo ele fica com o IP 192.168.254.2/30 e o mikrotik nesta interface o ip 192.168.254.1/24.

Na rota padrão voce coloca o gateway, certifique-se de estar cadastrando uma CIDR válida 192.168.0.0/16 por exemplo.

Quem tiver dúvidas em relação a CIDR http://pt.wikipedia.org/wiki/CIDR

monica massaro da silva

2011-06-22 14:45:47 Responder  

nessa sua topologia qual é os ip e mascara de rede que devo cadastrar na instalação do speedr ?

Andrio Prestes Jasper

2011-06-24 17:15:35 Responder  

Henrique
Voce demonstrou como seria a configuracao dele em paralelo, mas usando NAT

Aquela dica que voce deu ali para fazer o mascaramento de forma com que apareça o IP do cliente... ele serveria para que usa IP valido?

Henrique Fernandes Silveira
Developer
License Level: 8
2011-06-25 19:29:13 Responder  

Monica os ips devem ser escolhidos por você pode-se colocar por exemplo 192.168.254.2 com mascara 255.255.255.0 e 192.168.243.1 como gateway e colocar este ip no seu gateway.

Andrio se usa ip válido não precisa de mascaramento.

Andrio Prestes Jasper

2011-06-25 20:05:35 Responder  

Henrique.

E como ficaria a configuracao do speedr e do MK (redirecionamento) para quem usa IP valido?
poderia me dar uma ajuda nisso? quem sabe postar um exemplo (manual)?
pois realmente quero implementar o speedr mas estou em duvida nessa parte.

Mostrando 1 a 10 de 128 registros

Para responder este tópico ou criar novos é preciso efetuar login

Esqueceu a senha?

Dicas de Formatação

*ênfase*   **mais ênfase**

(4 espaços antes)código

> citação

* Um item de lista
* Outro item de lista

1. Um item de lista ordenada
2. outro item de lista ordenada

# Titulo primeiro nível (##, ###, ####)

[Texto Link](http://endereco.com)